Page 1 of 1

linking problems

PostPosted: Wed Jan 14, 2009 3:21 am
by sorcereral
I am using Cross Studio 1.4 build 3 with Salvo Pro 4.0.2 r.c. 2 on a MSP430F1612. Both Salvo and CubeSatKit examples build and run perfectly, but when I'm trying to build one of my programs, I get a linking problem:

undefined symbol '_OSInit'
undefined symbol '_OSCreateTask'
undefined symbol '_OSSched'

There is no other error or warning and I tried to follow as closely as possible the recommendations about building a Salvo project with CS430. I'm guessing there is something wrong with my configuration, but I couldn't find an answer in Salvo's documentation.


Re: linking problems

PostPosted: Thu Jan 15, 2009 1:28 am
by sorcereral
I noticed also that the library file doesn't compile. That might be the cause of the linking errors. I'm using the same library file as in the working examples.

Re: linking problems

PostPosted: Thu Jan 15, 2009 8:16 am
by aek
See Item 4) in the first post in this thread:
http://www.pumpkininc.com/ubb/Forum10/HTML/000014.html

------------------


Re: linking problems

PostPosted: Tue Jan 20, 2009 2:12 am
by sorcereral
Thank you! That solved my problem.