Page 1 of 1

Salvo RTOS & CCE3.1?

PostPosted: Mon Dec 15, 2008 2:56 am
by bgusat
Hello,
I am using salvo pro RTOS.
I understood from the User Manual that it should be possible to use any comiler i want.
is that true?
i would like to us TI's CCE3.1 compiler should i be facing any problems about it? thatnk you, bgusat.

Re: Salvo RTOS & CCE3.1?

PostPosted: Wed Dec 17, 2008 1:38 am
by bgusat
thank you,
just to be sure.
the IAR and Rowley's CrossWorks compilers are suited to workwith salvo RTOS and the CubeSatKit?
do you have a recomendation on one of them?
thank's again, bgusat

p.s
visit us at www.ee.bgu.ac.il/~bgusat


Re: Salvo RTOS & CCE3.1?

PostPosted: Wed Dec 17, 2008 1:43 am
by aek
Rowley and IAR are both suited to Salvo 4 for MSP430 ... However, we have only ported EFFS-THIN to Rowley for CubeSat customers. Therefore you must go with Rowley when using the CubeSat Kit.

------------------


Re: Salvo RTOS & CCE3.1?

PostPosted: Wed Dec 17, 2008 12:22 pm
by aek
No, Salvo must be ported to the particular compiler. We do not yet support CCE, neither for Salvo nor for the CubeSat Kit.

------------------


Re: Salvo RTOS & CCE3.1?

PostPosted: Thu Dec 18, 2008 6:56 am
by aek
Using anything other than Rowley, you won't be able to view the sample projects (in terms of their organization), and you won't be able to use software you paid for (EFFS_THIN for CubeSat Kit).

Much better to download and install Rowley, ask for an activation key, explain that you are students, and eventually purchase the educational license. The free version of CrossWorks for MSP430 is valid for 30 days, and they'll probably extend that for you if you ask nicely.

------------------


Re: Salvo RTOS & CCE3.1?

PostPosted: Thu Dec 18, 2008 12:27 pm
by bgusat
"We do not yet support CCE, neither for Salvo nor for the CubeSat Kit"

should i be facing troubles working with VubeSat Kit and CCE? even without Salvo RTOS? because until we will get new suitable compilers we planned to work with our CCE and the CubeSat Kit.
thank uou.