Pumpkin, Inc.

Pumpkin User Forums

Problems with v3.0.0 microVision2 Tutorial Projects

For issues specific to the 8051 family, including compilers (e.g. Keil C51) and IDEs (e.g. uVision2).

Problems with v3.0.0 microVision2 Tutorial Projects

Postby Salvo Tech Support » Mon Mar 18, 2002 10:41 am

We've found two small problems in Salvo's microVision2 tutorial projects. Here's how to correct them:

1) The projects have the Cygnal C8051F Driver selected as the debug target. If you don't have a Cygnal Development kit connected to your PC, you may experience difficulties with microVision2 when building the project. The solution is to use the simulator instead for debugging. To use the simulator, open the project (e.g. salvo ut u1sys1 u1free.Uv2), select "Options for Target 'Target 1'", select the Debug tab, and click on the Use Simulator radio button.

2) There is a line missing in the salvo ut u1main.h header file for these tutorial projects. Where you see

code:
#if !defined(USE_INTERRUPTS)
#define Init() do { config(); IE &= ~0x02; } while (0)
#define Init() config()
#endif

add an #else statement so that it looks like:

code:
#if !defined(USE_INTERRUPTS)
#define Init() do { config(); IE &= ~0x02; } while (0)
#else
#define Init() config()
#endif

We will incorporate these changes into the next Salvo for 8051 family releases.

------------------
--------
Salvo Technical Support
Please request all tech support through the Forums.

[This message has been edited by Salvo Tech Support (edited March 18, 2002).]

--------
Salvo Technical Support
Please request all tech support through the Forums.
Salvo Tech Support
 
Posts: 173
Joined: Sun Nov 19, 2000 12:00 am

Return to 8051 family

Who is online

Users browsing this forum: No registered users and 2 guests

cron