Pumpkin, Inc.

Pumpkin User Forums

Problems compiling tutorial 1

For issues specific to Microchip's PICmicro® MCUs, including compilers (e.g. HI-TECH PICC & PICC-18, Microchip MPLAB®-C18) and IDEs (e.g. Microchip MPLAB®).

Problems compiling tutorial 1

Postby rganter » Fri Jul 09, 2010 3:08 am

Hello,

I've been trying to compile tutorial 1. Unfortunately the linker exits with a strange error "unknown FNREC type "88"":

    Build C:\salvo\tut\tu1\sysa\tu1lite for device 16F877
    Using driver C:\Programme\HI-TECH Software\PICC\9.71a\bin\picc.exe

    Make: The target "C:\salvo\tut\tu1\sysa\mem.p1" is out of date.
    Executing: "C:\Programme\HI-TECH Software\PICC\9.71a\bin\picc.exe" --pass1 c:\salvo\src\mem.c -q --chip=16F877 -IC:\salvo\tut\tu1\sysa -IC:\salvo\inc -P --runtime=default,+clear,+init,-keep,+osccal,-download,-resetbits,-stackcall,+clib --opt=default,+asm,+debug,+speed,-space,9 --warn=0 -D__DEBUG=1 --addrqual=ignore -DSYSA -DMAKE_WITH_FREE_LIB -g --asmlist "--errformat=Error [%n] %f; %l.%c %s" "--msgformat=Advisory[%n] %s" "--warnformat=Warning [%n] %f; %l.%c %s"
    Make: The target "C:\salvo\tut\tu1\sysa\main.p1" is out of date.
    Executing: "C:\Programme\HI-TECH Software\PICC\9.71a\bin\picc.exe" --pass1 c:\salvo\tut\tu1\main.c -q --chip=16F877 -IC:\salvo\tut\tu1\sysa -IC:\salvo\inc -P --runtime=default,+clear,+init,-keep,+osccal,-download,-resetbits,-stackcall,+clib --opt=default,+asm,+debug,+speed,-space,9 --warn=0 -D__DEBUG=1 --addrqual=ignore -DSYSA -DMAKE_WITH_FREE_LIB -g --asmlist "--errformat=Error [%n] %f; %l.%c %s" "--msgformat=Advisory[%n] %s" "--warnformat=Warning [%n] %f; %l.%c %s"
    Executing: "C:\Programme\HI-TECH Software\PICC\9.71a\bin\picc.exe" -otu1lite.cof -mtu1lite.map --summary=default,-psect,-class,+mem,-hex --output=default,-inhx032 mem.p1 main.p1 C:\salvo\lib\htpicc\sfp42cmb.lib --chip=16F877 -IC:\salvo\tut\tu1\sysa -IC:\salvo\inc -P --runtime=default,+clear,+init,-keep,+osccal,-download,-resetbits,-stackcall,+clib --opt=default,+asm,+debug,+speed,-space,9 --warn=0 -D__DEBUG=1 --addrqual=ignore -DSYSA -DMAKE_WITH_FREE_LIB -g --asmlist "--errformat=Error [%n] %f; %l.%c %s" "--msgformat=Advisory[%n] %s" "--warnformat=Warning [%n] %f; %l.%c %s"
    Licensed for evaluation purposes only.
    This licence will expire on Thu, 19 Aug 2010.
    HI-TECH C Compiler for PIC10/12/16 MCUs (PRO Mode) V9.71a
    Copyright (C) 2010 Microchip Technology Inc.
    Error [375] ; . unknown FNREC type "88"

    ********** Build failed! **********

I am not shure if this is a compiler problem (I had quite a few other problems with this compiler version) or if it is a configuration problem.
The design tools used are:
- MPLAB IDE Version 8.50.00.00
- HI-TECH C Compiler for PIC10/12/16 MCUs (PRO Mode) V9.71a
- Salvo Lite for PICmicro
rganter
 
Posts: 1
Joined: Fri Jul 09, 2010 2:22 am

Re: Problems compiling tutorial 1

Postby nickbungus » Tue Oct 12, 2010 1:10 am

:? Hi

I'm having the same issue. Did you get it sorted? If so, how?

Thanks

Nick
nickbungus
 
Posts: 3
Joined: Tue Oct 12, 2010 1:08 am


Return to PICmicro MCUs

Who is online

Users browsing this forum: No registered users and 3 guests

cron