Pumpkin, Inc.

Pumpkin User Forums

Error [1239] with PICC18-PRO v9.61

For issues specific to Microchip's PICmicro® MCUs, including compilers (e.g. HI-TECH PICC & PICC-18, Microchip MPLAB®-C18) and IDEs (e.g. Microchip MPLAB®).

Error [1239] with PICC18-PRO v9.61

Postby mjsrs » Tue Dec 18, 2007 9:55 am

Hi everyone,

I'm trying to compile one of the tutorials and i can't build it.it gives me the following error:
Error [1239] C:salvosrcsched.c; 480. pointer S568tcb$tFP has no valid targets
I'm using MPLABv8.0,PICC18-PRO 9.61 and Salvo Pro.

I already apllied a patch provided on the HTSOFT forum that should correct another error:
"can´t generate code"
It really corrected it but now i have Error 1239.
Any help is welcome
Thanks in advance

mjsrs
 
Posts: 4
Joined: Tue Dec 18, 2007 12:00 am

Re: Error [1239] with PICC18-PRO v9.61

Postby aek » Tue Dec 18, 2007 10:16 am

PIC Pro compilers are not yet supported ...

From what we can tell from another user who has tried to use the PIC Pro compiler with Salvo, the errors you are encountering are not uncommon. Said user went back to the standard compiler, IIRC.

------------------

-------
aek
aek
 
Posts: 1888
Joined: Sat Aug 26, 2000 11:00 pm

Re: Error [1239] with PICC18-PRO v9.61

Postby mjsrs » Tue Dec 18, 2007 10:24 am

Any plans to support it in the near future.
mjsrs
 
Posts: 4
Joined: Tue Dec 18, 2007 12:00 am

Re: Error [1239] with PICC18-PRO v9.61

Postby aek » Tue Dec 18, 2007 10:44 am

Yes, Salvo 4 for PIC should be out in January ...

------------------

-------
aek
aek
 
Posts: 1888
Joined: Sat Aug 26, 2000 11:00 pm

Re: Error [1239] with PICC18-PRO v9.61

Postby aek » Thu Jan 24, 2008 2:20 am

Salvo 4 for AVR and perhaps one other target are ahead of it ... it's not looking good for January, but we are trying ...

------------------

-------
aek
aek
 
Posts: 1888
Joined: Sat Aug 26, 2000 11:00 pm

Re: Error [1239] with PICC18-PRO v9.61

Postby mjsrs » Thu Jan 24, 2008 10:11 am

Hi again,

Any news about Salvo 4 for the PIC's??

mjsrs
 
Posts: 4
Joined: Tue Dec 18, 2007 12:00 am

Re: Error [1239] with PICC18-PRO v9.61

Postby mjsrs » Thu Feb 14, 2008 2:22 am

Hello again,

Anything about Salvo 4 for Pics?
Sorry to be repetitive, but we have some projects that are depending on it.
Thanks

mjsrs
 
Posts: 4
Joined: Tue Dec 18, 2007 12:00 am


Return to PICmicro MCUs

Who is online

Users browsing this forum: No registered users and 1 guest

cron