Pumpkin, Inc.

Pumpkin User Forums

Error [1099] No MAKE_WITH_???

For issues specific to Microchip's PICmicro® MCUs, including compilers (e.g. HI-TECH PICC & PICC-18, Microchip MPLAB®-C18) and IDEs (e.g. Microchip MPLAB®).

Error [1099] No MAKE_WITH_???

Postby Tim_W » Wed Dec 28, 2005 6:32 am

I am new to this game, and am trying to set up a simple application, with Salvo LITE. I am using MPLAB ver. 7.22 and C18 ver. 3.0.

I persistently get the error:
salvoincsalvocfg.h:31:Error [1099] No MAKE_WITH_??? symbol defined. See salvocfg.h.

I have played around with including lines like this
#define MAKE_WITH_FREE_LIB 1
in the salvocfg.h file, but it doesn't seem to resolve.

Is there documentation on this in the manual, and an Errors listing? I could find little on either.

Any ideas?

Many thanks,

Tim

Tim_W
 
Posts: 6
Joined: Tue Dec 27, 2005 12:00 am

Re: Error [1099] No MAKE_WITH_???

Postby aek » Wed Dec 28, 2005 12:34 pm

Yes, it's in the manuals, but all you need to know is that for the PIC and MPLAB-C18, you need to define the symbol SYSE if your project includes any files (from Pumpkin) that support multiple targets (e.g. our salvocfg.h's and isr.c in the tutorial projects).

------------------

-------
aek
aek
 
Posts: 1888
Joined: Sat Aug 26, 2000 11:00 pm

Re: Error [1099] No MAKE_WITH_???

Postby aek » Wed Dec 28, 2005 12:40 pm

Oops, sorry, for that example, you also need to define MAKE_WITH_FREE_LIB (just set it to 1 in your salvocfg.h).

------------------

-------
aek
aek
 
Posts: 1888
Joined: Sat Aug 26, 2000 11:00 pm


Return to PICmicro MCUs

Who is online

Users browsing this forum: No registered users and 2 guests

cron