Pumpkin, Inc.

Pumpkin User Forums

about salvo version 3.2.3

For issues specific to Microchip's PICmicro® MCUs, including compilers (e.g. HI-TECH PICC & PICC-18, Microchip MPLAB®-C18) and IDEs (e.g. Microchip MPLAB®).

about salvo version 3.2.3

Postby Nutan » Wed May 11, 2005 2:29 am

I am Nutan Barshikar, R & D engg. of Krohne Marshall India.
previously, we have
1) Emulator of version 5.04.25
2) HI-TECH compiler PICC18 V8.30
3) Operating system Salvo of version 3.1.0
& we built the s/w using these versions. Since PICC18 V8.30 has some bugs, we change our compiler from V8.30 to V8.35PL3 before 2 days. Afterwards when we compile our s/w it gives some linking error regarding the operating system, so we change our operating system version(salvo) also from version V3.1.0 to V3.2.3(which is compatible with V8.35PL3)
our project has
1)3 tasks with events
2)we are using one interrupt & O.S services are not called in interrupt service routine.
3)The library file we are using is SFP82leb.lib & ew changed the salvocfg.h file accordingly.
But still it gives some linking error like,
Linking:
::undefined symbols:: (error)
::OSTcbP(..salvolibhtpicc18sfp82leb.lib:init.obj) (error)
::OSeligQP(-------------do---------)
::& many more

So please go through it & if possible suggest some solution on that. Hopping your fast response.
Regards,
Nutan Barshikar,
R & D engg.
Krohne Marshall Pune.
email:krhrnd@forbesmarshall.com
India
Nutan
 
Posts: 1
Joined: Tue May 10, 2005 11:00 pm
Location: Pune,Maharashtra,India

Re: about salvo version 3.2.3

Postby aek » Wed May 11, 2005 3:28 am

Hello.

It sounds like you have not included salvosrcmem.c in your project.

mem.c contains all of Salvo's global objects, and is required in every Salvo project.

Regards,

------------------

[This message has been edited by aek (edited May 11, 2005).]

-------
aek
aek
 
Posts: 1888
Joined: Sat Aug 26, 2000 11:00 pm


Return to PICmicro MCUs

Who is online

Users browsing this forum: No registered users and 3 guests

cron