Pumpkin, Inc.

Pumpkin User Forums

tut4 errors

For issues specific to Microchip's PICmicro® MCUs, including compilers (e.g. HI-TECH PICC & PICC-18, Microchip MPLAB®-C18) and IDEs (e.g. Microchip MPLAB®).

tut4 errors

Postby atabac_2000 » Fri May 07, 2004 12:13 am

I was trying to compiler tut4 when these erors occurred.

Here's the output:

Deleting intermediary files... done.
Executing: "C:HT-PICBINPICC.EXE" -C -E"mem.cce" "mem.c" -O"mem.obj" -I"SALVOTUTTU4SYSA" -I"SALVOTUTTU4SYSA.... u1" -I"SALVOTUTTU4SYSA......inc" -Q -MPLAB -16F877 -Zg9 -O -DSYSA -DMAKE_WITH_FREE_LIB

This compiler will expire in 16 days
Compiler operating in demo mode.
Some command line options are disabled and compilation is delayed.
Register this compiler to enable these options.

Executing: "C:HT-PICBINPICC.EXE" -C -E"main.cce" "main.c" -O"main.obj" -I"SALVOTUTTU4SYSA" -I"SALVOTUTTU4SYSA.... u1" -I"SALVOTUTTU4SYSA......inc" -Q -MPLAB -16F877 -Zg9 -O -DSYSA -DMAKE_WITH_FREE_LIB

This compiler will expire in 16 days
Compiler operating in demo mode.
Some command line options are disabled and compilation is delayed.
Register this compiler to enable these options.

Error[000] C:salvo ut u4main.c 34 : undefined identifier: OSecbArea
Error[000] C:salvo ut u4main.c 34 : pointer required
Error[000] C:salvo ut u4main.c 34 : pointer required
Warning[000] C:salvo ut u4main.c 34 : illegal conversion between pointer types
Error[000] C:salvo ut u4main.c 45 : undefined identifier: OSecbArea
Error[000] C:salvo ut u4main.c 45 : pointer required
Error[000] C:salvo ut u4main.c 45 : pointer required
Warning[000] C:salvo ut u4main.c 45 : illegal conversion between pointer types
Error[000] C:salvo ut u4main.c 60 : undefined identifier: OSecbArea
Error[000] C:salvo ut u4main.c 60 : pointer required
Error[000] C:salvo ut u4main.c 60 : pointer required
Warning[000] C:salvo ut u4main.c 60 : illegal conversion between pointer types
Halting build on first failure as requested.
BUILD FAILED: Fri May 07 16:17:29 2004

What possibly went wrong?

atabac_2000
 
Posts: 10
Joined: Sun Dec 14, 2003 12:00 am
Location: Antipolo, Rizal, Philippines

Re: tut4 errors

Postby aek » Fri May 07, 2004 7:36 am

Not enough information ... what is in your salvocfg.h?

And what happens if you build tu4lite.mcp from a clean install?

I suspect you've "moved up" through tu1-tu3 and now you're doing tu4 (which has events, and needs an e-config library), and your salvocfg.h has OSLIBRARY_CONFIG set to something other than OSE.

------------------

-------
aek
aek
 
Posts: 1888
Joined: Sat Aug 26, 2000 11:00 pm


Return to PICmicro MCUs

Who is online

Users browsing this forum: No registered users and 2 guests

cron