Pumpkin, Inc.

Pumpkin User Forums

IAR link problem

For issues specific to Microchip's PICmicro® MCUs, including compilers (e.g. HI-TECH PICC & PICC-18, Microchip MPLAB®-C18) and IDEs (e.g. Microchip MPLAB®).

IAR link problem

Postby wossy » Wed Oct 08, 2003 4:07 am

Hi

I am using the free version of Salvo and I am trying to compile the tutorial programs with IAR Embedded Workbench for the PIC 18. The tutorial compiles ok but when it tries to link I get this error message

Error[e88]: Library tag ?CLPIC18_2_10_L00 not found. Likely causes are compiler version mismatch, memory model mismatch or no library linked. Problem found in delay ( C:salvolibsfiar18-slna.r49 ).

I have tried changing the lib file but this makes no difference.

wossy
 
Posts: 2
Joined: Fri Apr 11, 2003 11:00 pm
Location: hull

Re: IAR link problem

Postby aek » Wed Oct 08, 2003 9:55 am

Hello.

This occurs when the compiler used to build the libraries does not exactly match the one used to build a Salvo Lite application.

Please refer to Linker Error: Undefined External (version number) in App Note AN-15's Troubleshooting section.

AN-15 is for IAR's MSP430 C compiler, which probably behaves much like their PIC18 C compiler w/regard to this sort of thing ...

------------------

[This message has been edited by aek (edited October 08, 2003).]

-------
aek
aek
 
Posts: 1888
Joined: Sat Aug 26, 2000 11:00 pm

Re: IAR link problem

Postby wossy » Thu Oct 09, 2003 12:06 am

ok thanks for that I will take a look
wossy
 
Posts: 2
Joined: Fri Apr 11, 2003 11:00 pm
Location: hull


Return to PICmicro MCUs

Who is online

Users browsing this forum: No registered users and 1 guest

cron