Pumpkin, Inc.

Pumpkin User Forums

Problems Building with MPLAB-C18

For issues specific to Microchip's PICmicro® MCUs, including compilers (e.g. HI-TECH PICC & PICC-18, Microchip MPLAB®-C18) and IDEs (e.g. Microchip MPLAB®).

Problems Building with MPLAB-C18

Postby aek » Tue Jul 08, 2003 4:47 am

To all MPLAB-C18 + Salvo users.

We just recently worked with a customer who could not successfully build projects that we had no trouble building in the lab.

With exactly the same project and files and directory structure, and with the same command line being shown in MPLAB's Output window, our build would succeed, but their build would fail because the salvocfg.h file could not be found.

Here's a successful build of that project:

Deleting intermediary files... done.
Executing: "C:mcc18inmcc18.exe" -p=18F452 "mem.c" -fo="mem.o" /i"c:motronavr10" /i"c:salvoinc" -Opa-
Executing: "C:mcc18inmcc18.exe" -p=18F452 "avr10.c" -fo="avr10.o" /i"c:motronavr10" /i"c:salvoinc" -Opa-
Executing: "C:mcc18inmplink.exe" /l"c:mcc18lib" /k"c:mcc18lkr" "C:mcc18lkr18f452.lkr" "C:salvosrcmem.o"
"C:MOTRONAVR10avr10.o" "C:salvolibmcc18slc18sft.lib" /m"C:MOTRONAVR10avr10.map" /o"avr10.cof"
MPLINK 3.40, Linker
Copyright (c) 2003 Microchip Technology Inc.
Errors : 0

MP2COD 3.40, COFF to COD File Converter
Copyright (c) 2003 Microchip Technology Inc.
Errors : 0

MP2HEX 3.40, COFF to HEX File Converter
Copyright (c) 2003 Microchip Technology Inc.
Errors : 0

Loaded C:MOTRONAVR10avr10.cof

In the end, the user uninstalled MPLAB-C18, then re-installed MPLAB-C18 v2.10 and then the v2.20 upgrade, and all problems vanished.

So, the moral is that there may be some include-path-related issues with MPLAB-C18 that are affected by its installation. Best to use the defaults when presented during installation.


Posts: 1888
Joined: Sat Aug 26, 2000 11:00 pm

Return to PICmicro MCUs

Who is online

Users browsing this forum: No registered users and 1 guest