Pumpkin, Inc.

Pumpkin User Forums

Warnings Compiling with AQ430

For issues specific to TI's MSP430 line of ultra-low-power microcontrollers, including compilers (e.g. Quadravox AQ430), IDEs (e.g. IAR Embedded Workbench) and development tools (e.g. TI MSP-FET430 Flash Emulation Tool).

Warnings Compiling with AQ430

Postby Eduardo Robles » Wed Apr 28, 2004 12:21 am

Hi Andrew,

I am getting a bunch of warnings (harmless, so far) while compiling a source build for the MSP430F149 with he AQ430 ver2.0.5.9

Thew look like:

Warning: Circular Reference in include files! (c:salvoincSALVOSCG.H)

I'm getting 9 of those at the very begining and the rest of the compilation goes smooth.

I went thorough SALVOSGC.H but there should be nothing to do with the AQ430 itself.

As said, it doesn't stop or interfere with the normal working of the program, but I don't like warnings inside my robots unless I tell them to...

Any ideas?

Eduardo

Eduardo Robles
 
Posts: 14
Joined: Mon Jun 18, 2001 11:00 pm
Location: Sao Paulo, SP, Brazil

Re: Warnings Compiling with AQ430

Postby aek » Wed Apr 28, 2004 12:44 am

Hi Eduardo.

Dunno -- I'll take a look.

------------------

-------
aek
aek
 
Posts: 1888
Joined: Sat Aug 26, 2000 11:00 pm

Re: Warnings Compiling with AQ430

Postby aek » Thu Apr 29, 2004 10:26 am

OK -- it's an AQ430 IDE problem -- the IDE is not noticing that the #include "salvoscg.h" on line 25 of salvoincsalvoscg.h is within a comment .... only occurs in source-code builds, and only when you load the project.

To fix for now, un-read-protect that file, and place a // ahead of the offending commented-out #include directive.

I'll tell Michel.

------------------

[This message has been edited by aek (edited April 29, 2004).]

-------
aek
aek
 
Posts: 1888
Joined: Sat Aug 26, 2000 11:00 pm

Re: Warnings Compiling with AQ430

Postby Eduardo Robles » Sat May 01, 2004 6:48 am

Funny that...

Anyway, it did the trick.

While Michel fix it, I'll be carefull with my commented descriptions for my modules.

Thanks!

Eduardo Robles
 
Posts: 14
Joined: Mon Jun 18, 2001 11:00 pm
Location: Sao Paulo, SP, Brazil


Return to TI's MSP430

Who is online

Users browsing this forum: No registered users and 1 guest

cron