Pumpkin, Inc.

Pumpkin User Forums

Downloading Programs to MSP-FET430UIF

If you have a general question or comment regarding the CubeSat kit, post it here.

Downloading Programs to MSP-FET430UIF

Postby BlackKnight » Wed Jan 21, 2009 10:54 am

I am completely new to cubesat and satellites in general so forgive me if I posted this in the wrong forum. Right now I am ready to push some software down to the developmental board. The IDE I am using is CrossWorks, however whenever I try to connect to the MSP-FET430UIF target it tells me that I need a firmware upgrade. I checked the web and the Texas Instruments website and a firmware upgrade for this target does not seem to exist. Any help is greatly appreciated.
BlackKnight
 
Posts: 4
Joined: Wed Jan 21, 2009 12:00 am

Re: Downloading Programs to MSP-FET430UIF

Postby aek » Wed Jan 21, 2009 11:54 am

IIRC you right-click on the MSPFET-UIF target and select "Firmware Upgrade".

I.e. it's supported by the Rowley IDE. If you can't find it, you can ping Rowley for support.

Alternatively (and I am not recommending this because it may cause confusion), but if you install IAR's QuickStart EW430, it can do the upgrade of the FET as well ...

------------------

-------
aek
aek
 
Posts: 1888
Joined: Sat Aug 26, 2000 11:00 pm

Re: Downloading Programs to MSP-FET430UIF

Postby applewood » Wed Feb 18, 2009 6:33 am

We had the same type of problem last spring. At that time Rowley provided us with a file that updated the firmware on the FET. Check the post "FET430UIF to Dev Board Interface" further down this page. Hope it helps.
applewood
 
Posts: 17
Joined: Wed Apr 23, 2008 11:00 pm


Return to CubeSat General

Who is online

Users browsing this forum: No registered users and 1 guest

cron