Pumpkin, Inc.

Pumpkin User Forums

USB Target FETs in CubeSat

If you have a general question or comment regarding the CubeSat kit, post it here.

USB Target FETs in CubeSat

Postby cpbridges » Mon Jan 21, 2008 4:42 am

Hi there,

I'm now using a 30-day trial to test and use CrossStudio (v1.4) which I've compiled tasks for the FM430 Board. But I'm having a problem in connecting to the board to reprogram the device. I've written a few details that might help.

Hyperterminal runs fine (with the usual temperature output). The error is with TI MSP430 USB-Debug-Interface (MSP-FET430UIF) which gives 'cannot connect to target', etc. I've read AN-35 and found that my CubeSat disc's directory tree is completely different to the one in the AN. The drivers that are installed are from the cubesatusbdrivers.zip for win-xp off the site (very different to the ones in the AN). I do not have the FET drivers as in the AN.

Can you recommend a 'next step' so that I do not damage the FM430 board?

Cheers, Chris

cpbridges
 
Posts: 21
Joined: Thu Aug 10, 2006 11:00 pm
Location: Guildford, Surrey, UK

Re: USB Target FETs in CubeSat

Postby aek » Mon Jan 21, 2008 8:31 am

The files on the CSK website are the correct ones ... but the ones you have are for the CSK, not for the FET. Those are here: http://www.cubesatkit.com/driver/thirdparty/fet/ti/

TI is no longer including the drivers on the TI CD-ROM ... so that's one reason why they're available/archived via the CSK website as well.

------------------

-------
aek
aek
 
Posts: 1888
Joined: Sat Aug 26, 2000 11:00 pm

Re: USB Target FETs in CubeSat

Postby cpbridges » Tue Jan 22, 2008 3:36 am

OK, thanks for that. But where do these go? Do I need to replace the 2 drivers I have for the serial and usb link?
cpbridges
 
Posts: 21
Joined: Thu Aug 10, 2006 11:00 pm
Location: Guildford, Surrey, UK

Re: USB Target FETs in CubeSat

Postby aek » Tue Jan 22, 2008 3:44 am

The FET USB and CSK USB drivers are completely unrelated.

Simply unzip the FET drivers to any directory and then point to that directory during the Windows USB discovery process ... Windows will put them where they need to be. As per AN-35.

------------------

-------
aek
aek
 
Posts: 1888
Joined: Sat Aug 26, 2000 11:00 pm

Re: USB Target FETs in CubeSat

Postby cpbridges » Tue Jan 22, 2008 4:05 am

Yes, as soon as I click "Submit Reply", I knew I'd made a mistake!

I'm just connecting the FM430 module and not the CSK Development Board. Once connected via USB, I do not get any more screens to install any FETs. Is it possible to program the FM430 module like this or am I missing a tool/ require the dev. board?

Thanks for your patience in this! Chris

cpbridges
 
Posts: 21
Joined: Thu Aug 10, 2006 11:00 pm
Location: Guildford, Surrey, UK

Re: USB Target FETs in CubeSat

Postby aek » Tue Jan 22, 2008 5:29 am

In order to program the FM430, you need to use the USB FET along with the 14-pin-header-to-flat-ribbon-cable adapter that was included in your CubeSat Kit.

Additionally, you should connect the FM30 via USB to a PC -- this ensures that the FM430 is powered from a robust +5V source when programming the FM430. Alternatively, you can use the +5V power supply to power the FM430 when programming via the USB FET.

------------------

-------
aek
aek
 
Posts: 1888
Joined: Sat Aug 26, 2000 11:00 pm

Re: USB Target FETs in CubeSat

Postby cpbridges » Tue Jan 22, 2008 7:09 am

Ah I see, I only have a Parallel Port MSP430 Flash Emulation Tool v1.4 (not a USB one) and use the USB tool to maintain the robust +5V.

I'll follow the AN-34/35 as best as I can and load this driver on manually to use LTP1 (or whichever) as it will only detect plug&play devices through WinXP. You think this'll work?

Many thanks, Chris

cpbridges
 
Posts: 21
Joined: Thu Aug 10, 2006 11:00 pm
Location: Guildford, Surrey, UK

Re: USB Target FETs in CubeSat

Postby aek » Tue Jan 22, 2008 7:13 am

Parallel FETs don't need drivers. Just plug it in and it will work with Rowley.

------------------

-------
aek
aek
 
Posts: 1888
Joined: Sat Aug 26, 2000 11:00 pm

Re: USB Target FETs in CubeSat

Postby cpbridges » Tue Feb 12, 2008 7:46 am

Hi Andrew,

I got it working finally to find that I needed my proper license before I could download (my 31-day one expired). I followed you post "Getting started with the CubeSat" and just get some strange output from the HyperTerminal:

1:000001:000001:000001:00000 à1:00000

Have you ever seen this before? My project file is CubeSatKit_Dev_BoardTestTest1RA430Pro-libDebug est1pro-lib.hzx which downloads and verifies successfully.

Edit: I'm working on the FM430 Board, do I need different header file for pins, etc?

[This message has been edited by cpbridges (edited February 12, 2008).]

cpbridges
 
Posts: 21
Joined: Thu Aug 10, 2006 11:00 pm
Location: Guildford, Surrey, UK

Re: USB Target FETs in CubeSat

Postby aek » Tue Feb 12, 2008 7:59 am

That just looks like you have the wrong baud rates set -- must be 9600,N,8,1 for what comes out on the USB connector.

Code is identical between Dev Board and FM430.

------------------

-------
aek
aek
 
Posts: 1888
Joined: Sat Aug 26, 2000 11:00 pm

Next

Return to CubeSat General

Who is online

Users browsing this forum: No registered users and 1 guest

cron