Pumpkin, Inc.

Pumpkin User Forums

MHX2420 Power

Discussions pertaining to the electrical issues (e.g. circuitry, power, etc.) of Pumpkin's CubeSat kit.

MHX2420 Power

Postby pswpsh » Sat Apr 02, 2011 2:04 pm

Hi,
I'm using the development board Rev D,
and when I plugged only J1, LEDs D10, D11, and D13 light up but D12(PWR_MHX) doesn't.
The voltages across those LEDs are:
V(D10)=3.6V, V(D11)=2.5V, V(D12)=0.9V, V(D13)=2.2V.
Voltage across power and GND pins in the MHX transceiver socket ~ 1.6V

If I also plug the USB simultaneously, V(D12)=0V.
Can somebody explain why D12 doesn't light up and how I can make it work?

Thanks,
Sung
pswpsh
 
Posts: 1
Joined: Sat Apr 02, 2011 1:53 pm

Re: MHX2420 Power

Postby aek » Tue Apr 05, 2011 10:25 am

Please use signal names, not D(iode) numbers.

Test Points for signal names on a Rev D Dev Board are on the right edge and are listed below:

TP9: +5V_SYS (D10) = 5V
TP10: PWR_MHX (D12) = 5V when MHX is powered and JP 24 is jumpered on the left side
TP12: VCC (D11) = 3.3V
TP44: VCC_SYS (D13) = 3.3V

My guesses are:

1) That you have not turned on MHX_PWR -- you need to take -ON_MHX low (0V) to enable power to the MHX socket.

2) That you are running the MHX-2420 at maximum power, and it is drawing more than ca. 2.2A through U12. Do the test without the MHX in place. Then, use the AT command set to write to the power register (S107?) and write to memory (AT&W?) to use a lower power level. The MHX2420 apparently uses much more peak power than the datasheets say ...
-------
aek
aek
 
Posts: 1888
Joined: Sat Aug 26, 2000 11:00 pm


Return to CubeSat Electrical

Who is online

Users browsing this forum: No registered users and 1 guest

cron