Pumpkin, Inc.

Pumpkin User Forums

Missing libraries in Salvo from Hi-Tech?

If you're having difficulty installing Salvo, post it here.

Missing libraries in Salvo from Hi-Tech?

Postby gerardlt » Mon Mar 08, 2004 3:07 am

Hello,

We've been working with the Salvo RTOS on a PIC18 for several months now. Limitations with PICs have lead us recently to consider using an MSP430 chip on future projects.

I downloaded the IAR EW kickstart system, and started following Pumpkin's document AN-15.

My problem is that when I came to add a library to the project, I couldn't find any with the appropriate name (or indeed, any with "430" in the name).

We purchased Salvo from Hi-Tech (version 3.1.0). Does the product, as bought from Hi-Tech, not include pre-built libraries for non-PIC micro-controllers? As we're still within the support period, can we download these libraries? (or could they be emailed to us?)

As we're using the Pro version, we could build the libraries ourselves, but we'd prefer to avoid such 'big tasks' so early on while experimenting with the new tools.

Any suggestions?

Cheers,

------------------
Gerard Thornley
Electron Software

Gerard Thornley
Electron Software
gerardlt
 
Posts: 14
Joined: Tue May 13, 2003 11:00 pm
Location: Lancaster, UK

Re: Missing libraries in Salvo from Hi-Tech?

Postby aek » Mon Mar 08, 2004 7:29 am

Hi Gerard.

Salvo distributions are specific to a particular target.

E.g. Salvo for PICmicro(R) MCUs contains only those files (source and libraries) for PIC microcontrollers.

For MSP430, you'd need to obtain Salvo for TI's MSP430.

------------------

-------
aek
aek
 
Posts: 1888
Joined: Sat Aug 26, 2000 11:00 pm

Re: Missing libraries in Salvo from Hi-Tech?

Postby gerardlt » Mon Mar 08, 2004 9:25 am

Any chance of a discount considering we're already using it on another architecture?

Would it have to be installed in a separate folder?

Regards,

------------------
Gerard Thornley
Electron Software

Gerard Thornley
Electron Software
gerardlt
 
Posts: 14
Joined: Tue May 13, 2003 11:00 pm
Location: Lancaster, UK

Re: Missing libraries in Salvo from Hi-Tech?

Postby aek » Mon Mar 08, 2004 9:37 am

Hi Gerard.
quote:
Any chance of a discount considering we're already using it on another architecture?
Since you purchased HI-TECH Salvo, you'll need to take that up with them (HI-TECH) directly.
quote:
Would it have to be installed in a separate folder?
All of the Salvo distributions install to the same folder (salvo). You can install Salvo Lite MSP430 "over" Salvo Pro PIC without any problems, should you wish to test the IAR EW MSP430 + Salvo for TI's MSP430 combination.

------------------

-------
aek
aek
 
Posts: 1888
Joined: Sat Aug 26, 2000 11:00 pm

Re: Missing libraries in Salvo from Hi-Tech?

Postby gerardlt » Mon Mar 08, 2004 9:39 am

Thanks. :-)
Gerard Thornley
Electron Software
gerardlt
 
Posts: 14
Joined: Tue May 13, 2003 11:00 pm
Location: Lancaster, UK


Return to Installation

Who is online

Users browsing this forum: No registered users and 1 guest