Pumpkin User Forums
  TI's MSP430
  Problems with IAR's MSP430 v3

Post New Topic  Post A Reply
profile | register | preferences | faq | search

UBBFriend: Email This Page to Someone! next newest topic | next oldest topic
Author Topic:   Problems with IAR's MSP430 v3
aek
Moderator
posted February 21, 2005 09:53     Click Here to See the Profile for aek     Edit/Delete Message   Reply w/Quote
IAR MSP430 v3.21A users will get a "incompatible runtime model" error when trying to build the existing Salvo projects.

To solve this problem, download the Salvo update salvo-lite|le|pro-msp430-3.2.4-b.zip and unzip the files to the Salvo directories. Replace the Salvo library in each project with a library of the same from \salvo\lib\iar430-v3.

E.g. replace tu4lite's sfiar430-e.r43 with \salvo\lib\iar430-v3\sfiar430-e.r43.

The project should then build without warnings or errors.

------------------

IP: 63.203.232.106

aek
Moderator
posted April 28, 2004 15:08     Click Here to See the Profile for aek     Edit/Delete Message   Reply w/Quote
Libraries compatible with IAR Embedded Workbench MSP430 V3, which contains the IAR MSP430 C compiler v3.10A, are now available in the download areas.

Please download the salvo-lite|le|pro-msp430-v3.2.3-b.zip archive and follow the directions in the included readme.txt file.

------------------

IP: 63.203.232.106

aek
Moderator
posted April 07, 2004 14:00     Click Here to See the Profile for aek     Edit/Delete Message   Reply w/Quote
Hi.

We have not yet received the v3 MSP430 compiler from IAR. As soon as we do, we'll update the Salvo distribution to include libraries that are compatible with the new runtime model used in v3.

In the meantime, if you can find a copy of IAR MSP430 EW v2 (or v1), they're both supported in the current Salvo release.

------------------

[This message has been edited by aek (edited April 07, 2004).]

IP: 63.203.232.106

Unregistered User
Member
posted April 07, 2004 13:58     Click Here to See the Profile for Unregistered User     Edit/Delete Message   Reply w/Quote
Hello.

I can't get the Salvo tutorials to work with the latest IAR MSP430 Embedded WorkBench v3.

Can you help?

IP: 63.203.232.106

All times are ET

next newest topic | next oldest topic

Administrative Options: Close Topic | Archive/Move | Delete Topic
Post New Topic  Post A Reply
Hop to:

Contact Us | Pumpkin Home Page

2000-2008 Pumpkin, Inc. All Rights Reserved. Pumpkin and the Pumpkin logo, Salvo and the Salvo logo, The RTOS that runs in tiny places, CubeSat Kit and the CubeSat Kit logo are all trademarks of Pumpkin, Inc. All other trademarks are the properties of their respective owners.


Ultimate Bulletin Board 5.46a